Problem syncing data from Garmin

The new Garmin’s activities don’t sync or update in I have to upload manually

This discussion might help:

Hmm Garmin isn’t sending me anything for you. Are these activities recorded using a Garmin device? Garmin doesn’t send activities from other sources to If so you can try disconnect and reconnect to Garmin connect and see if your next ride works.

Hi, does this mean if i’ve used trainer road and have Garmin selected to push my activities through to Intervals they won’t show up and i actually need to connect with Strava to see them appear?


thanks, i anwser your questions:

Is the data showing when you don’t filter on those dates? No
What type of activities do you have showing? Running, Ride, Swim, etc.
It could be commutes, which is unticked (by default). When did you join, and are you waiting for it to populate? I’ve just populated, the problem is the new activities don’t sync
Have you been active in the last 28 days? yes
To save Strava API call, you need to be active within a 28 day period. with garmin connect API

Are these activities recorded using a Garmin device? Yes
Garmin doesn’t send activities from other sources to If so you can try disconnect and reconnect to Garmin connect and see if your next ride works. i’ll try

my activities have private visibilty in Garmin connect, is it a problem?

Yes, that is what David is explaining; Garmin said they stopped pushing to 3rd party apps unless recorded on a Garmin device.

I don’t have that problem, at least with rides from Zwift, which are automatically pushed here.

thanks… unfortunately the same doesnt seem to be true for trainer road, unless i’m not doing something right, which is always a possibility… :slight_smile:

I don’t think you’re doing anything wrong, if it’s coming from TrainerRoad and stopping at Garmin.

I use Garmin Fenix 6 and it works perfectly for me. It goes both ways. Scheduled are sent to Garmin and executed by Garmin at Couldn’t find any errors. Unfortunately not helpful for you… But it’s probably because of the settings. If necessary, disconnecting Garmin completely and reconnecting it again is a good approach.

I can see your most recent activity came from Garmin Connect so it looks like whatever you did has sorted things out.

Yes!!! i disconnected and reconnected. thanks

Hi @david my Garmin activities have stopped coming through as of today. I have tried reconnecting etc. but no success. Also, when i try to import the .fit manually i get an error message.

This is the error message if a try manual upload - * FIT decode error: Unexpected end of input stream at byte: 0

Hi there,

I experience the same issue, my last sync was 7:05 CET timezone today. After that I can’t manually pull “Old activities” either, nor automatic sync working.

It sounds like that fit file might be empty (zero length). Do you mind checking that. If it isn’t empty please mail it to Tx.

@Valentin_Kardos I can see a 500 error from Garmin trying to fetch your new activities. This is likely a temporary problem. But if you are in a. hurry you could download the file from Garmin Connect and manually upload. You won’t get dups.

Have emailed you the file @david

@david i tried uploading again this morning and it worked. Also, did a short walk and that uploaded ok this morning so whatever the problem was it appears to have gone for now.

Thanks. I just tried your file on my laptop and it worked fine. Not sure what happened there.

My recent data isn’t pulling through. I don’t know why? Any help?