Heartrate spikes now automatically fixed

Heartrate spikes are detected and fixed by comparing the HR trace to your max HR. Spikes above max HR are replaced with a line interpolated between the HR values before and after the spike. If the HR data for an activity is very poor you can ignore the HR trace by clicking the cog icon. You can see the unmodified HR trace by clicking the charts button and adding Raw HR.

3 Likes

Sorry, I must be blind, but where do I set my max heart rate? I must have done it somewhere, simply based on the max HR that my HR tracker had seen so far, but what if that, in fact, is not my max HR and I want to fix that (rather than have my HR spikes “fixed”)?

1 Like

Click the “HR Training Zones” in /settings. Your max HR is the number on the bottom right hand side of the grid.

I just added max HR to the zones text and made that entry on the grid bold. You are not the first person to struggle with this.

Excellent. Thanks a lot!

So am I reading this correct? You set your max HR by changing the value in the bottom right cell of the grid? When I do that I get an error message: “Invalid HR zones”.

Each zone still needs to be higher than the one below. Can you post a screenshot of the zones that won’t save?

So if all I want to do is lower my max HR I will have to setup all the zones? I don’t remember doing that initially. I have a feeling I’m being stupid :thinking:

Ah I think I was :man_facepalming: I have to set my LTHR and then adjust the max HR?

You can enter your LTHR, then click “Calculate” and then edit your max HR in the bottom right hand corner.

@David , how can I revert the “fixing”?

I had guesstimated my maximum heart rate to N, now I got a HR trace which contained a (two?) HR reading(s) of N+1 (literally N+1;-) and I believe that was correct – smooth curve and at maximum workload… Thus, I changed my max HR in the general settings to N+1.
I also reprocessed todays workout from its original file, but it keeps saying “Heartrate spikes over your max HR of N bpm have been fixed”… I don’t want it to do that or, really, I want it to honor the updated setting;-)

You need to do Actions → Update zones. I just did that for you on that activity.

1 Like