Swim distance occasionally slightly wrong

I’ve had a few time where my swim was recorded on Garmin as 1000m but only showed up as 999m on intervals.
Watch is a Forerunner 945, doesn’t seem to happen all the time, but enough that if I’m chasing a PB I’ll tend to swim another 25/50 to be sure.
Today was 5 x 200m, then 2 x 50m to finish off, but somehow the first 1 is recorded/reported as 199m.
Activity is here: Intervals.icu

It could be something I’m doing, and if there’s a way of me not stuffing it up or editing I’d happy with that.

Neither my son (FR735) nor girlfriend (FR745) seem to have the same problem, or at least neither have noticed it…


Another example, proving (to myself in part) that it is distance travelled not just interval that’s off, is this one below. Was part of a triathlon event, my fastest 400m, but doesn’t make the record in intervals, because it’s only a 399m activity.


I am looking into this. It appears there is an “off by 1” error that impacts the whole activity and the first interval.

I think it is fixed. I did Actions → Reprocess file on your two examples and that first interval is now 200m and you get your 400m record. Those swims had the first length starting 1s before the recordings. Tx for picking this up.

Many thanks David.
Definitely looks fixed to me, has resolved all the other anomalies I could find.

Your time to resolve issues outstanding as always!

PS. when reprocessing files, it appears to clear the “ignore pace data” flag, was a little tricky to find and manage those as there is no “ignore pace data” column in list view.
I (and presumably others) use, ignore pace a bit on swims, if Garmin misdirects distance it’ll create a massive “performance spike” that pollutes the pace curve.
If you’re curious this is an example of what a “free” 25m can do to pace curve, this was a moderate pace effort, that became records over most distances for the season. And Garmin can be out by a whole lot more than that (especially when doing drills).

is it possible to make “ignore pace” available in list view please?

Tx. I have added ignore pace to the columns available in the list view. The others were there, missed that one.


Let me paraphrase above.
Your time to resolve issues and add features is astonishing!


It’s happened again…
Am I doing something wrong, or has the previous bug reappeared maybe?

Latest example here: Intervals.icu

Different problem this time. That one has a missed time tick that I wasn’t accounting for. It’s fixed now. Tx.


Great to hear, it also fixed some of my errors, where the distances were slightly off.

I have an additional issue, sometimes pool lengths are not correctly counted by the garmin (mainly someone cutting in my lane → the sudden break throws the garmin off). As of course intervals.icu can’t do anything about it, the pace is artificially high in this cases. Nevertheless, the detected “best” times for, e.g. 200m, 400m, etc. are artifically high, which in turn messes with my pace charts for the season. Is it possible to delete these “Best for xx in season” chips for certain workouts?


I have used this before,

you can merge the lap where garmin has inaccuracy as it will have two half laps

delete the original fit file and load in the modified saved one to garmin connect and let it sync through to intervals.icu

It may help you out



Thanks @David, awesome response time as usual.

@s_kli you can Actions - Settings - Ignore Pace Data will let you drop a swim off the pace curves/best efforts.

@Wazc23 That looks good, I’ll be keen to much around with trying to fix some minor shambles in some swims (actually think I had the same experience @s_kli was describing last night, but was late so hadn’t looked closely yet).