[SOLVED] Edit/Delete Paces

So I went running while on a cruise ship, and my GPS went haywire and tracked my movement alongside the ships movement. It 100% screwed up my “season’s best” in terms of pacing. I can’t seem to find a way to simply delete the bad paces from the activity. Is there a way to simply delete the paces from the activity, or would simply deleting the activity fix my issue?

As much as I’d like to flex, running 400M in 1 second is a smidge too fast :smiley:

1 Like

Within the activity, click Actions (bottom of page), then Settings and you can tick the Ignore pace data box.

Ignore the velocity data

That worked. Thanks!!