Paired workout not showing in calendar

Hi all. Older workouts show the paired workout in the calendar view. Within the past few activities, there’s a simple generic graphic that only shows intervals if I manually add them. Bug or something I am doing incorrectly or did to break it? Thoughts?


Should show this paired workout:

Used to look like this:

Did you disable the News notification function?
If so, I would suggest re-enabling it. If not, please take a quick look next time.
Your answer is in the first topic.

If disabled, go to /Settings page
You’ll find the News button there.

Thanks for the quick replies.

Missed the bit about turning it on/off. The old activity showing correctly threw me off thinking I did something wrong. Its behaving like I would like now. Thanks again.