No Speed Data - Strava import

Hi - I’m using FitnessSyncer to bring in my Strava Virtual Rides. I noticed there is no Speed data in Intervals, though it’s there in Strava.
Not sure if this is a Fitness Syncer issue or a setting in Intervals or something else.
I did add a speed chart, and it has not data (in Intervals).

Try this…

Under Intervals Data, click on “original file” (mine is TCX - so its a simple text file, if its FIT then more trouble to view. Alternatively, use the “streams CSV” which will give you a comma separated file with data for each of the fields)

Speed data should be there.

  1. If you see Speed data in Strava, then the (org) upload from Strava has Speed Data
  2. if you don’t see speed data in Intervals, the data from your FitnessSyncer App may have done something or it’s intervals.

to check #2, i suggest you check the data from FitnessSyncer (not used this app so you will need to see how you can view the data that’s exported out from fitness syncher somehow)

Oy. I think I made it worse.
I thought I’d just delete everything and try doing a direct sync with Garmin first, and bypass Fitness Syncer.
So I deleted all the activities - a couple months worth.
Disconnected from Garmin.
Reconnected to Garmin.
Set a date a few months back.
Nothing coming in. Presumably because I had set up a sync earlier then disabled it.
How do I reset the connection to Garmin so it starts over?

someone else has to chime in here. I have no clue. sorry.

Ok. I tried to undelete everything I deleted. I suspect that is still in process, so I’ll have to deal with those if they come back.
In the meantime, I just requested my entire history from Garmin which actually only took about an hour, and I imported the whole thing into Intervals. Then I connected to Strava, and as folks said, with the exception of two duplicates, the whole thing worked right, renamed Garmin activities, etc. So I think I’m all set and I ditched Fitness Syncer altogether.

1 Like

Glad you got it sorted. Garmin limit calls to their backfill API (you cannot request the same data twice) so the “undelete” function usually doesn’t work. I still need to make a plan for that.