Incorrect/missing pace curves for running and swimming

First of all, I am pretty amazed by how powerful and feature-rich this platform is. Unfortunately, I also stumbled upon a couple of bugs, like these:
I am a triathlete with plenty of running activities, so the following graph should contain at least some data - I am pretty sure this is a bug.

The graph for swimming does show data, but I am not sure which data it is - I need at least 1:20 per 100m, not 5s as this chart claims. This seems to be to extreme to be caused by one lap being counted multiple times, so I suspect there is a bug here.

Tx. I just looked now and could see running pace curves. If they are still missing for you try reloading the page.

For pool swims uses the length records to generate streams to plot. So if there is any issues with the lengths you can get strange results. You can click through to that super fast swim from the marker and have a look at it.

If you go to the data tab showing the table of intervals you can see 400m in 41s in the middle. There isn’t a way to exclude parts of the activity from pace curves yet but you can do Actions → Settings and tick the “Ignore pace” box.

1 Like

Hi, thanks for the quick reply.

I still do not see any running pace data. The data was imported through Strava followed by a Garmin Connect Sync. I have not uploaded a run since creating my account. I will see whether this changes in the near future.

The swim paces up to 400m are due to a user error on my part during the recording. The other weird paces seems to be a consequence of the same error.

EDIT: Removed suggestion that was already mentioned in the reply.

Ah you had only the “Indoor” box ticked in “Pace Curves”:

If you tick “Outdoor” as well then your curves show up. I should build those filters into the “No matching activities with Pace found” message.

1 Like

Thanks, that seems to have fixed it. So two bug reports that turned out to be user errors, nice result.

1 Like