Cropped Strava activity won't sync / sync fail is silent

Either just silently reloads original or (at some point, but mostly not) gives an arrayindex OOB exception. Confirmed my own app gets updated data.

At some point after starting to write this post a few hours ago it appears to have worked itself out, maybe you saw the error and fixed it already? If not lemme know and I’ll dig up the activity IDs.

In any case I would classify failing silently as a bug as well - should always be explicit if something goes wrong, definitely makes reporting easier.

I didn’t change anything. So you cropped a Strava activity and then it refused to sync? If you can give me the activity ID I might be able to find something in the logs. Tx.

Indeed. Normally updates by itself, noticed it didn’t so tried manual sync which either reloaded same old data or gave the OOB error. Started writing above post, left for a few hours then came back to finish and noticed activity had updated at some point. This was all the day after upload (followed a few minutes later by crop) so nothing should’ve changed at that point really. And like I said I confirmed through my own app that Strava was always giving the new data. Spooky!

7149128912 is the ID.

I had a look and can’t figure out what happened. Hopefully it doesn’t impact too many people in future.